Getting Super Pikix Pi working

Hey all,
Now that I’ve figured out the issue with my Waave Pool setup (wrong model of Pi) I had one more program I’d love to get working to see what it’s like. It’s the Super Pikix Pi here:

I’ve tried following the initial instructions and didn’t have any luck getting it to work. It seemed like there was an issue with the install_dependencies.sh , but I’m not sure. I’m no programmer, so I just kind of struggle my way through this stuff haha.
Let me know if you have any tips.
Thanks!

just from glancing at the super pikix pi page it looks like the last update was 2017, you might want to try installing it on an concurrent version of raspbian from around 2017
https://downloads.raspberrypi.org/raspbian/images/
and that could help with the dependencies issues

Gave that a shot. Tried an img from early 2017, and one from June 2017 (just before the latest version of Pikix), and neither seemed to work. Both of them seemed to not be able to pull files and gave a bunch of errors which I took a picture of.

looks like the dependencies from that install script either don’t exist anymore, or don’t exist at the locations that script expects. the only way i’d see this project being easy to install is if you can find someone who has a pi (same model as you) with this thing already installed and running on an image, and they then make a copy of the entire image to share with you the same way that i distribute the VSERPI stuff

Thats what I was afraid. Thanks so much Anderi, really appreciate your help. I might try reaching out to the person who made it as I’m interested in the PS2 program they made also. Maybe they still have a working one laying around.

Yes, those files don’t exist anymore on the raspian dependencies mirrors.
But, very similar files do. You could edit the script:
Try changing:
libxmu-headers_1.1.2-1_all to libxmu-headers_1.1.2-2_all.deb
libxmu-dev_1.1.2-1_armhf.deb to libxmu-dev_1.1.2-2+b3_armhf.deb
opencv-data_2.4.9.1+dfsg-1+deb8u1_all.deb to opencv-data_3.2.0+dfsg-6_all.deb
libassimp3_3.0-dfsg-3_armhf.deb to libassimp4_4.1.0~dfsg-5_armhf.deb
libassimp-dev_3.0-dfsg-3_armhf.deb to libassimp-dev_4.1.0~dfsg-5_armhf.deb

These are long shots as these versions may not be compatible with Super Pikix.

If I find an old raspberry pi laying around here somewhere, I’ll try to install it and see if I can find a method of getting the ‘right’ versions.

Never mind. I just looked at the script and it references by generic names like ‘libassimp-dev’, not specific versions.

Thanks for trying for me! I got a hold of the person who made this, and they’re looking to see if they have a working SD card. Fingers crossed.