Notes/suggestions for the 1.4 update

I’m starting to play around with the new versions of Spectral Mesh and Auto_Waaave and so far I really like the new stuff, and motion recording is already very usable and is going to open up a ton of possibilities. I’ll post suggestions or potential bugs I encounter in this thread.

For starters, a few things about motion record:

  1. When motion record is on, the most recent recorded parameter doesn’t take effect until I adjust the next parameter. What this means is that the last parameter adjsuted with motion record on won’t actually have its motion played back.

example:
-motion record on
-record some moves on the rotate fader. As I move it the rotation changes as expected, the recorded motion doesn’t play back.
-now record some moves on the Z displace. As soon as I start changing it, the recorded rotate motion begins to play. The recorded Z displace motion doesn’t play until I adjust another parameter.
-etc. etc. - the last parameter adjusted will never have its motion play back because it is waiting for another parameter to be adjusted.

  1. The way you have it working now, when motion record is toggled off it freezes the parameters at their current value. I think it would be a lot more useful if turning off motion record allowed the recorded parameter changes to keep looping, so that it would be possible to record changes for some parameters, switch motion record off and make static adjustments, and repeat as needed. Static adjustments made to parameters that had motion recorded could act as offets or scaling factors for the recorded motion (both would be pretty interesting, I couldn’t say which would be better without trying them)

  2. Using the existing Nanokontrol preset, the three MARKER buttons (G, H and I) don’t light at all when pressed. I think in general it would be better if they toggled between lit and unlit, but especially now that Spectral Mesh uses G/SET for toggling motion record - not having a visual indicator of whether it’s on or not is awkward. Easy enough to change myself with the editor, but unless there’s something I’m missing it should probably be part of the standard template.

That’s all so far, over all it all works really well and seems as stable as the previous versions. I won’t have a chance to mess with audio input in auto_waaave until tomorrow night at the soonest but I’m really excited to see how it interacts with motion record!

2 Likes

thanks much, some stuff is being worked on already, didn’t know that you could set those toggles to light up tho and thanks so much for letting me know! please everyone keep this kind of stuff coming! i’m pretty much building the whole motion recording thing from scratch and theres a lot of stuff i don’t quite have the ability to acheive quite yet without learning a lot more about the process.

1 Like

Actually I don’t think you can unfortunately, I hadn’t tried yet when I posted and I’m pretty sure I misremembered. I haven’t used a Nanokontrol for anything but your programs quite a while.

Even as-is the motion recording is great. Your stuff running inside of feedback loops between two mixers is a big part of what I do now.

Actually I’ll have to test more after this stream, but as far as I can tell audio reactivity in auto_waaave doesn’t work at all anymore. When I turn on an audio control toggle now the faders stop responding completely until I turn it back off.

EDIT: haven’t had a chance to go back and test more yet, but I do want to say that feed-forward+toroidal universe+motion recording inside of a mixer feedback loop is really nice.

finally getting a chance to get properly stuck into the new update (mainly WP). great work, @andrei_jay, everything feels more responsive and dynamic, and getting into wild zones is even more intuitive than before.

random question, but is it possible to control the rPi versions of these softwares via a Mac, or an iOS/android device using a direct USB connection? or is that something that’s only gonna be possible once you get OSC implemented?

1 Like

hmmm ok, let me take a look at that. every so often drivers fail at the auto loading on boot for me (not sure why) but then using keyboard and mouse to restart once booted seems to fix it? otherwise the last gen images are all still available to use. let me know the full hardware set up yr running so i can try to duplicate

yes exactly, trying to add full osc functionality along with audio reactivity and cv compatibility in one full swoop by march

3 Likes

I’m in he middle of rearranging my whole setup so things aren’t hooked up right now but I’ll try to replicate it as soon as I can. I’m using a Pi 3B+ with one of those EasyCap dongles that you can get everywhere, with the audio inputs patched to a pair of audio outs on the Sony FXE100 so I can use its master fader as a sort of global depth control. Never had an issue with the previous version so it’s probably the driver not loading like you suggested, I just haven’t been able to spend time with it yet since it happened.

Love the new features, so hopefully it will just work the next time I boot it up.

ezcaps can be a real pain to work with my auto waaaves image and theres kind of a limited scale of how well i can design these to work out of the box with everything out there. that being said there are some hacky tricks available to help, they aren’t exactly going to make shit plug n play but it can help on a case by case basis. drop me an email if you want to learn more, would probably require a short video call to diagnose and explain things.

Weird, I’d been using them without any trouble with all of your stuff since last summer, and it still works fine for video it’s just the audio that didn’t seem to be working since the update. I guess I was lucky. I should have things set up again by tomorrow evening, maybe it’ll just work next time, and if not I always planned to pick up a Hifiberry for it eventually, so maybe it’s time.

Just FYI I got the Hifiberry today, installed it, still nothing. I checked the config.txt file and dtparam=audio=on is commented out, but uncommenting it made no difference. I’ve checked all my connections and I’m getting a good, hot line level into the Hifiberry. I tried changing the device ID from 1 to 0 in the Openframeworks EasyFft source and making/rebooting as per the included text file, but it made no difference - audio input simply isn’t working with the HifiBerry and I haven’t been able to find a reason. Any idea what I’m missing here?

EDIT: I’ve tried different cables, a different audio source, the previous version of Auto_Waaave and a entirely different Raspberry Pi and nothing has worked, so either the Hifiberry isn’t working or there’s something I need to do to that I haven’t found in any of the documentation on the website, Github or included on the actual image itself.

The light on the Hifiberry comes on and stays lit when I power up.

@andrei_jay - I just wanted to second the issue @TubularCorporation has been documenting with audio reactivity on auto_waaave - I’ve tried a few different things as well, including multiple cables and images, with no success. I am using a recently-purchased HiFiBerry ADC/DAC HAT.

(First time posting - also just wanted to say thank you for all these awesome open source tools!)

Have you been able to confirm that your Hifiberry is working? If you boot up with a USB mouse and keyboard connected and hit ESC to quit auto_waaave you should have Audacity installed, you can use that to make sure you’re getting audio from the HifiBerry. I did it yesterday and was able to record a bit of incoming audio with no problems, so it’s not a hardware issue here. I’ve also tried switching to the recommended capture dongle just in case and that didn’t make a difference. I’ve also tried using the capture devices’ audio inputs just to make sure.

Another thing I’ve noticed is that if I turn the audio modulation up all the way for a parameter there’s a very, very slight change. It still doesn’t respond to incoming audio at all but there’s a tiny bit of fixed offset added to the current parameter value. It’s very small - imperceptible on most parameters - but you can see it if you apply full modulation to the X, Y or Z position - with the modulation all the way up there will be maybe 3 or 4 pixels of offset added.

The red light on the HiFiBerry comes on for 5 seconds or so when I turn on the Pi. Audacity shows the audio coming in / can record it.

I had tried setting “stream.setDeviceID” to (0) yesterday (it was at (1) to start with). Today I tried setting it to (2), but there was no difference in behavior.

One thing I am wondering is if it could have anything to do with the controller mapping. Basically what I am seeing is that I press A/B/C, change a dial, nothing happens, and then when I deactivate A/B/C the value of that slider jumps to wherever I moved it to. There is no audio-related movement - just a single jump to the new value, where it stays static. Additionally, J resets everything for me, not just the audio-reactive mappings…I’m wondering if maybe the functions of J and K have been switched or something? Anyway, I hope these notes are of some help!

I don’t think it’s likely that it’s a controller mapping issue. The old USB image works perfectly for me, but both the old and current HifiBerry/DAC images behave the way you’re describing.

The light on my HifiBerry stays lit as long as the Pi is running. The one thing I haven’t done yet is check the kernel version, since the note about needing to update the kernel to make the Hifiberry work is from 2019 and already referred to older kernel versions back then so I just assumed the Auto_Waaave images were using a newer kernel.

The whole thing is very strange, especially the older image having the same problem. I don’t know my way around Linux enough to really dig much deeper than I already have.

still working on this, its seemingly something to do with the order in which drivers/devices are getting identified and loaded is my best guess at the moment. if the old usb image is working for yalls without issues thats pretty helpful knowledge tho!

1 Like

The old ADC image isn’t working for me either. the old USB image works with the audio inputs on every kind of USB 2.0 capture device I have. If it’s helpful I can check the HifiBerry PCB to see if there’s a version number or anything useful, and if there’s anything else I can do to help out please let me know.

chat.scanlines.xyz