Raspi/Vserpi Struggles

Hey all,
I’ve recently taken the plunge into the DIY Vserpi/Pi video based world, and I’m having some issues that I’m hoping to get some help with. I’ll do my best to try and keep this concise and non-tangental, but I’ve gone down a lot of avenues trying to get this stuff running so forgive me if I ramble XD.

I’ve acquired a few Raspi 3b+s that all say version 1.2 on the board. I’ve been trying to get either one of Andrei’s programs working, or some of the similar ones that exist (Scrawl, Super Pikix Pi). So far I’ve only gotten one thing to work which is the general video looper found here https://videolooper.de/. All of the other programs either just give me a black screen, freeze on the splash screen, or freeze on the loading text page. hitting esc etc doesn’t seem to do anything.
After getting frustrated with all that I decided to try and run Super Pikix Pi by loading the Jessie Os onto the Pi (as per the SPP instructions), and transferring the SPP files onto the Pi using a USB drive. I put the files on the desktop, but any time I try to run anything for it in terminal I get a “command not found” or “no such file or directory”. I didn’t know if putting the files on the desktop might be the problem there. Is there a certain folder I would need to copy the files in to for the Pi to see them from terminal?

To check off some of the common problems here are things I have/have already checked.
I have a good power supply (no lightning bolts), the correct composite cable for the Pis, and a 16gb Sandisk SD card (I’ve also tried others just in case). I have a USB webcam that has worked on a Strange Loop, so I’m assuming it will work here too. I have a NanoKontrol 1, and I have updated the midi settings using the Korg App. I have a USB keyboard that I plug in along with the NK.

Thanks for any help you can give. I’m no programmer, so a lot of this has just been google searching and a lot of copy and paste, but this is such a niche thing that finding specific answers has been hard. Appreciate your time!

What software are you using to burn the SD card images?

I can recommend starting with 32bit Raspberry PiOS; and maybe checking if your firmware and bootloader (eeprom?) need updating.

I would also recommend starting out with HDMI output (RPI default); and worrying about composite output later.

The reason you are having trouble executing things from the desktop is because they are not in your PATH. You can see your path by typing echo $PATH. I don’t recommend editing your path until you understand it better. Instead you can use the ABSOLUTE path; or my preferences make a new folder in your home directory.

Absolute Path:
Right click on a file and maybe there is “properties” which will show you the absolute path. maybe it is /home/pi/desktop.

Some helpful commands
cd - change dir
pwd - print working directory (where am I?)
ls - list files
mkdir - mkdir
rm - remove file or dir.
whoami - use in case of existensial crisis’

I like to install the TLDR package, which I think is more helpful than the man command.

Thank you so much for your help!
I’ve been using balenaEtcher on a 2020 Macbook Pro using a usb C adaptor that takes microSDs. I verified that it’s the latest version of balenaEtcher.

I’ll start working on your recs and update with my progress.

Ok, I now have a working image of the latest 32bit OS on a card. I also ran the firmware and bootloader updater. I’m still not able to get Super Pikix Pi working, but I’m afraid that might be because it needs an older OS. How can I get Waave Pool on this working image without having to reflash the card?

Tried AL on a different SD card and this is what I got. After trying to log in a few times it just freezes. No response to keyboard etc.

I tried the same card in a RetroPie setup I have, and it worked immediately. The Pi in the case is a 3b, so at this point I’m going to use the trouble Pi for something else, and just order a 3b. Thanks for the help all.

Waaave Pool sd image problems - #4 by sinewave440hz here is another thread where folks have been working on the 3b+ issue for anyone looking to explore this further, i’m currently officially not supporting any of the new 3b+ models and just telling folks to use regular 3b

Hey all. I figured out the issue with my situation, and embarrassingly it was that I didn’t have 3b+ Pi’s. Mine were just b+ which is why nothing really worked except the video player img. Sorry I didn’t catch that sooner, I appreciate the attempted help, and apologize for wasting anyone’s time. I’ve sourced a 3b, and everything works as intended.