Recurboy Display not working


I partly assembled the recurboy today, but unfortunately the display is not working.
Till now, just the Pi, Buttons and the Display is soldered, but according to the schematics, this should be fine.
The display should be also the right one, it’s this one here:

The Pi itself is running, becasue I can see some videos running over RCA .
Any Ideas ?

Btw: i already replace the display with another one, with no luck.
I took the latest Gerber files and the lastes image

Can you take some pictures of your soldering and installed screen?
Are you using the latest image for the Recurboy?

Maybe I missed something very obvious. These are just a few components, so I think there should not so many things which could be wrong. My assumption is, that due to the fact that the ADC is not installed, the init routine from the display stucks.
The backlight is working. I measured all the pins to the display, and all of them have proper connection

Am I right, the display should work as soon as the raspberry has booted, or? Or is there something else what I have to do?

Sw is v2.1
I tried also different PIs

The display will work AFTER the Raspberry Pi has booted. It is initialized later in the booting chain as it is not a ‘video’ display (attached to HDMI or composite output) but is a peripheral. Mine shows a white screen and then colored ‘static’ until it is completely initialized.

What do you see on the composite output?

Mine is not on the latest software. I’m making an SD card now to see if mine still works on the newest software…

on the composite, I can see the videos if i press “blind” the Buttons. So the Pi is already running

Just finished flashing the latest to mine and it booted up fine.

Hmmm. Not sure what is going on.

I’ll wait for the other components and try it again.

The only thing I’m doing differently than you is I’m using Eurorack to power mine.

Is your USB power supply up to snuff? No lightening bolts in the upper right corner of the screen?

Tried mine with USB power, and it worked fine.

Sorry I’m not being much help…

I tried it also with a better power supply, same issue.
Very strange

Okay, maybe I am complete stupid , but I tried so far

with no luck, the display shows nothing, over the RCA output it’s working.
Can someone confirm that the recurboy should run out of the box without, directly from the fresh flashed SD card, without any modification.

Can someone send me the link to the right Firmware (yes I consider that i am stupid)
Does someone have an alternative link to a display which is definitely working

the strange thing is, I cannot measure anything on the display lines with my scope.
Do I have activate SPI for the display ?
The Pots are working, I can control the shader

@cyberboy666 do you have an idea how to troubleshoot?

Hi @korb - im sorry the build is not working for you ! It sounds v strange and frustrating.

It also sounds like you hsve been doing everything right. I have no idea why this is happening. I order my screens from the exact same seller as you have linked, and iv built maybe 30 of these over the last 6 months and havnt had problem like this.

I did have q similar sounding issue with some of the screens not working on the older version (v6_0) of pcb. And after some frustration i discovered that the data pin from pi to screen needed a thicker trace to work with some screens … which is what the revision to v0_7_1 is for. But i can see that you have that version so it is quite confusing. Especially since you tried multiples already.

Some things i would try at this point:

  • if you manually connect the screen pins to the rpi pins with jumper leads does it work then ? (This is how i discovered the trace problem on older version)
  • if you run the examples that come with the screen drivers directly, do these work ? You can ssh into the pi0 by plugging a usb cable from its data micro usb (not the power one) to a computer. Tjen once it boots open your terminal/putty and connect to pi@raspberrypi.local - from here the examples are in ~/Python**** something folder in home dir. I will give more info when im in studio.

You can still find the link to the old firmware download - could b worth testing with this too. Although i doubt thats the problem

another thing you can check is that theres not a short being created by the top of the rpi header touching back of screen - it shouldnt happen but putting some tape or foam bbetween them to be safe can be an idea.

Finally what we can do is i can send you a screen from my stock thwt is tested and knon to work on my tester recurboys. Then atleast we know if the problem is your batch of screens (as i suspect) or something else on your end. You can send me also the faulty screens and i can test them at my end also if you want.

I will send through links when im in studio qlso

wow, thank you very much for the detailed answer.
I tried a couple of things and no it’s working. It’s really strange, but I found another zero w which was similar to the one i tried before, and it worked.
What it is really confunsing me, is the fact that on all pi’s (three) i tried, the usb port was not working. I never recognizing this before, because they run he in headless mode, I cannot image how i destroyed on three PI’s the usb port. I am confused. But hey, recurboy is running, and it’s awesome

1 Like

oh wow thats great news !

yes very strange. not having a working usb port. and that somehow also meaning screen over spi doesnt work? :thinking: weird
but im glad u got it in the end ! (and im relieved to hear that its not faulty screens from the manufacture as i was suspecting…)

This Project driving me really crazy. Can someone support me how to upload new Videos.

usb-drive method

the easiest way to play clips is by putting them on a usb drive in a folder called: /Videos - and connect it to the data-micro-usb port on the pi with a usb-on-the-go cable like this:


ssh method

you can also transfer files onto the recurboy sd card quite easily if you have ssh / putty on ur computer already:

power it up through the data-usb-port to a usb-a on your computer, and then in your terminal / ssh client try connecting to the address:

ssh pi@raspberrypi.local

the password is raspberry

if that works then you are connected to the pi ! now you can use scp to transfer files over… soemthing like:

scp /path/to/your/video.mp4 pi@raspberrypi.local:~/Videos/

Thank you for your endless patience and support. I really appreciate it.
I don’t want to give the impression that I have no idea what I’m doing, I have more than 20 years of DIY experience in HW and partly in software. But this project really challenges me, I feel like I’m sitting in the Raspberry Pi Bermuda Triangle.

The good news first, yes I managed to display new videos. My findings are:
The USB ports (at least on my Pi) don’t seem to work when I simultaneously (!!!) use an external USB power supply (2.5A) and the recurBoy is connected to the monitor with HDMI. If I connect the Recurboy to a USB port of my computer, or discconect HDMI, it works. Very strange

Not all USB sticks are supported Kingston 8GB no, Intenso64 GB yes.
It’s so easy, you just need the right combination of USB port and stick. :slight_smile:

SSH via Putty does not work, although the recurboy is recognized as a device, I get the error message.

But anyway, it works now via USB

Thanks for this great project and again, your support.

1 Like

Can you try the IP address of your RaspPi instead of raspberrypi.local?

its good feedback for me to know where the pain-points and difficulties are for people building this project. the intention was for it to be as beginner friendly and accessible as possible…

so i appreciate you letting me know how its going ! im using pop_os (an ubuntu derivative ) so can only guess how things are interfacing with windows.

that is strange ! i assume u already know this, but just checking - only one of the usb-slots on the pi0 sends data - the other is only for powering the unit:

i will do some tests re hdmi connected and usb sticks. the hdmi function is new to this latest firmware - before then recurboy was cvbs only… every usb i tried has worked but ya i cant test all usb sticks eitehr ! so thnx for feedback

1 Like