recurBOY external video not recognized

I am trying to use external video input into the recurBOY. I am using a USB UCEC capture device. Most times I start the device the “3rd Mode” shows up but sometimes it does not. The CVBS video signal never shows up though. I have tried hitting “select” and nothing… “Play” and nothing… Anyone have any advice for passing a live video signal into this device? Note, I also watched the video tutorial on YouTube by @cyberboy666 to confirm I am performing this operation correctly as best I can tell. Only thing I can think is that my capture card is not compatible. I have linked a usb capture device below. It is unbranded but looks exactly like the UCEC model I have.

USB Video Capture Device, RCA to USB Video Converter, Video Capture Card VHS/Mini DV/VCR/Hi8/DVD to Digital Converter for PC TV Tape Player Camcorder, Support PAL/NTSC, MAC Windows Vista Compatible

The only thing i can think of is to make sure you plug the usb-micro power supply into the correct slot (outer one labelled pwr ) and then the usb otg adatpter connected to the capture card on the inner usb-micro labelled data

If thats correct then qnd it doesnt give you the 3rd source mode on boot i would say it may not be compatible…

If you get the option then it atleast thinks there is a video device there… double check your source is outputing video and the capture card is working in general (you could test capture from your source into usb on computer using obs)

There are many versions of those capture cards. Most do work but some dont. If you would like to open it up and tell me what the chip inside is i can confirm if its one i have had working or not :slight_smile:

1 Like

@cyberboy666 Images should be below… first time posting any so not completely sure I loaded them correctly

Any chance these Photos helped to identify if the converter is known to work @cyberboy666


Using an AUGUST VGB300 usb Adapter AND second unbranded Adapter I am getting video through both BUT… The video passing though is stuttering very inconsistently and never plays through in real time. Any help with a tested Known working usb video adapter would be most appreciated. Thanks!

i thought i had a UTVF007 one around here somewhere but i cant find it right now…

found it.

just tried with my UTVF007 card… it recognized it in the menu but at first was only outputing black screen. after unplugging the input and plugging back / waiting a short moment tho the video came through…

second time i tried this it came through straight away

heres an example of the “stablity”

maybe its a power supply issue on your end @PigPin ? how many amps u sending ?

1 Like

these are the two i have rn in my studio - both seem to work w recurboy last i checked

1 Like

@cyberboy666 I’ve tried the one you sent… plus another Raspberry Pi Branded Power Supply rated exactly the same. They are both 5.1v, 2.5A, 12.75W. Should I try to reflash the Software? All I would do is use etcher and flash the installed card with your the most recent image on your GitHub correct?

ah yeah official supply should be more than enough…

yeah i would try flash the firmware - i cant remember if your one was sent out before the recent update.

1 Like

No luck with the flash… thanks for the help though. I’ll update this thread if I find any solution.


Apologies if this would be more suitable for another thread but how high of frame rate are people able to get with the video-in? I’m using an easycap right now and have also tried an old Logitech webcam. Both work but are pretty low frame rate (about 5-10 fps). Just want to make sure I’m maximizing its optimization and just meeting the limits of the pi0. Still a great addition to an already feature packed little device.

Edit: after rewatching the demos it seems it could be higher frame rate. I’ve also noticed some shaders overwhelm mine and don’t function properly. Does anyone know if there are notable performance differences between versions of pi0?

1 Like