RecurBOY usb don'work

Hi, I’m new to the group, and new to Linux, but for many years in video art, and always in DIY. …I recently built a recurboy (which I find wonderful, and very stimulating to grow) on Raspberry Pi zero wh… …among the various difficulties that I have found, there is one that puts me in great difficulty… …it doesn’t read my USB OTG port (keyboard, mouse, midi, memory), yet with an OS downloaded for processing, everything works… … I did various tests on config.txt and cmdline.txt in boot (suggestions found online), but it doesn’t work… Do you have suggestions? Thank you
(Google translate)

1 Like

first thing i always check with these issues is that the correct usb port is being used - since on the rpi0 one of them is for power only while the other can be used as data with otg

Thanks cyberboy 666!!
Congratulations to recurboy (and recur that I’m studying) great work!!
The ports are right, I soldered some cables to the pads, for ports to be placed external to a box, (power supply under Power USB, data + and - under OTG), or even tried with another OS (to experiment with processing) and the USB works fine.
I’m thinking of trying to load an older version, to see if the USB works.

(Google translate)

1 Like

…to try to understand more, I purchased a Raspberry pi3b+, loaded the SD with recurboy…
…and it is not read (green LED flashes and stops, and continues like this).
I try to flash the SD again, but the result is the same.
I reload the SD to zero, and it starts again, again without USB
I try another system on pi3 (just to make sure it’s not broken), and everything works fine…
…I’m afraid I have to study a lot…

thank you glad you are enjoying!

yes if the exact same ports work on the same pi running a different image then this does point towards ruling out hardware as the issue…

however it is strange since i have tested that image on many rpi_zeros and otg cable works in all these cases…

what version of the rpi0 are you trying with ?

maybe if you post some pictures it will be easier to help debug

i have tried running recurboy image on pi3b+ in the past and it has worked but havnt tried this recently…

im guessing you dont have another rpi0 handy to try swap with ?

also swapping the otg cable is worth a try (although the fact its working with other image suggests its not this…)

finally could be worth getting to the terminal (you will probably need to ssh in on recurboy image) and checking lsusb - this should give info on any usb devices attached / failing etc

Thank you for the replies. Here is the photo of the Pi zero, and my prototype version of recurBOY Now I don’t have any other Pi zeros available, but a friend with Pi zero 2 tried to load the image, and it loaded, without additional hardware (keys, TFT and pot), with HDMI and USB keyboard, with which he exited the program and browsed the folders, in the next few days I’ll meet him and let’s try to connect his Pi zero 2 to my hardware. Then I will try to make the ssh connection and use lsusb, …I was thinking of returning the pi3b+ and taking a pi zero 2… …but I would prefer to resolve and understand with both of you… Thank you so much
(I’ll also post a photo of Pi3b+)

Finally! the USB port started working, as I commented #dtoverlay=dwc2 in config.txt
Keyboard ok
Midi ok
Easycap currently gives me error -71 and “device not accepting address 8”, but I hope to resolve it
Thank you!

1 Like

Oooh thTs very interesting to know thank you ! Not sure what the hardware difference is between ur pi and mine but will keep this in mind for future tests / updates ’ let me know how it goes with easycap

…I discovered another small difficulty, when I return to recurboy, after being in the terminal, the controls do not work (pot, CV in and midi… The midi interferes in the movement of the shader, but does not modify)… Has this already happened to others?

1 Like

This is a known bug - it comes from the ooenframeswork library that is used to read from spi adc. You just need to restart the pi for ut to work again - annoying for dev work like what you (and i) are doing, but shouldnt effect most users…

1 Like

Thanks again! maybe it’s better that I stop my head for a while, and enjoy the beauty of recurBOY inserted into my setup (there’s so much to discover already like this… :star_struck:)

1 Like