Trying to get Video Waaaves to work on ubuntu

Hey all! I’m new to linux and trying to get Andrei Jay’s Video Waaaves program up and running on an ubuntu machine. I downloaded openframeworks and was successfully able to compile and run the polygon test graphic but am having a hard time getting any of the apps in the VSEDSK to compile and run. Is the best way to do this in an IDE? I ran the make command in the video waaave app directory and it keeps spitting out an error saying I downloaded it for the wrong platform, stop. I moved all the apps to my openframeworks directory and it actually started compiling but errors out with expected initializer before ‘aCachePath’
884 | ofCubeMap::_loadIrradianceMap(const of::filesystem::path & aCachePath)

If anyone can give me some advice on how to build and run this successfully that would be amazing. Also wanted to say thanks to Andrei for developing these open source tools for us to use!

Got a little further while trying to get this to work but still not there yet. I verified openframeworks is indeed installed correctly and working and I added all the addons from the waaave pool repo to my openframeworks directory but it still will not finish compiling. It keeps erroring out addons/ofxImGui/src/Helpers.cpp:28:37: error: ‘struct ofxImGui::WindowOpen’ has no member named ‘usedNames’
28 | while (std::find(,, result) !=

I’ve reinstalled this addon and even verified in the source code that everything is correct. I have no idea what else to try, any advice?

I don’t have any answers for you, but I will say that the VideoSynthesisEcosphere Discord might have more people who can help. I see people often troubleshooting issues like this over there. VideoSynthesisEcosphere

Hey! Thanks so much for replying, I actually posted there first a couple days ago but some more people joined the server since so my messages may have been a little buried. I’ll make another quick post over there

i have never had much luck setting up IDE for video waaaves in linux, i just use make commands and things usually work well, but some hardware sets aren’t super cooperative with bringing in usb video

the best way to do it is not by manually installing openframeworks, libraries, and adding VSEDSK, but by downloading the whole VSEDSK suite from my website and compiling from there. its already contains a custom version of openframeworks with libaries added already, so you would just mainly need to run the script to install packages, maybe track down any packages if they aren’t installing correct from oF script, and then run script to compile oF, then just use make commands to recompile each synth and at that point you should be good

Thanks for responding to the post Andrei, been AFK a couple of days so was just able to try to get this working again. Also wanted to give myself ample time to try everything I could before coming back to make a post.I tried following your instructions to compile from the VSEDSK and run the scripts but I’m still having some trouble. Since there was no Linux install scripts in the scripts folder of the VSEDSK zip, I placed the ones from a new openframeworks zip in there and tried to run them to install openframeworks from the VSEDSK zip and I keep getting errors usually no rule to make target. This happens when I try to compile both the videowaaaves app and Starting to think this might be more trouble than it’s worth and that I should just do this on windows where you already made a great video tutorial for.