Uploads on videos.scanlines.xyz stuck at "video is being transcoded"

An .mkv/h264 file I uploaded 5 days ago is currently stuck with the message “The video is being transcoded”

The same is happening with 2 short clips I uploaded 15 minutes ago (and these ones are identical to clips which I had previously uploaded without any issues, and which became ready a few seconds after the upload)

I was trying to walk @andrei_jay through uploading the archive for the recent streaming show today and we were having some issues as well. unfortunately i don’t really know my way around peertube well enough to help diagnose further. @cyberboy666 do you have any ideas why this would be happening?

Semi-update: the two clips I had uploaded just before opening the thread got transcoded 5 hours later and are now working.

The previous upload (“Pixelflowers logo”) instead is still stuck. There’s a chance I’ve encoded it in an unfriendly way, as I was experimenting with ffmpeg…but that wouldn’t explain the delay with the two other clips or @palomakop’s problems.

I’ve tried uploading just now, but the process fails (after the actual upload, apparently during the transcoding) with a “Server error. Please retry later” message.

No urgency about this being fixed. but also I’m available and happy about doing more tests or whatever if it can help.

we also saw the same “server error” message. thanks for the info !

yeah i am kind of in the dark about what seems to be going on behind some of the scenes with the peertube uploads. yesterday i spent more or less the whole day trying to upload the ephemeris time show in 1 hour blocks and it seemed pretty much random as to wether the upload would work but not transcode, would fail halfway through and just reload the submission page, or upload but not show up in ‘my videos’ for several hours? everything seems to have worked after many tries except for i think one of the blocks has been stuck in ‘transcoding’ for about 24+ hours straight? if anyone has any advice on if theres anything i can do on my end in transcoding that would make things operate a bit smoother lmk!

also i think i successfully made a playlist of what has been uploaded and functional so far, https://videos.scanlines.xyz/my-account/video-playlists/4a72bfdd-f6b9-43ef-8ca3-a653b347dcce not sure if this is only visible from my account or if playlists are public on this peertube thing?

the playlist is public but you need to share the public link, which i think is this: https://videos.scanlines.xyz/videos/watch/playlist/4a72bfdd-f6b9-43ef-8ca3-a653b347dcce?videoId=8eb17b62-b81f-4ff0-bb64-f30682664076

i’m glad things at least seem to be working after some retries and wait times. i’m not sure how long the transcoding normally is supposed to take, or if things are getting stuck but not throwing an error. i guess we’ll see if they pop out eventually.

1 Like
  • I deleted the video that was still stuck at the transcoding step
  • I uploaded different files, and they got transcoded and published in a matter of seconds
  • I reuploaded the same file, and again it got stuck there
  • I uploaded other files, no visible problems

So it’s likely there’s something wrong with that file. If anyone wants to analyze it, it can be downloaded here. But also, it doesn’t look like this file is preventing other files from being processed.

I guess the server has already been checked for basic things like CPU load, free space, syslogs? I also don’t have any clues nor I could find anything useful among the Peertube bug reports.

thanks for testing @pixelflowers ! yeah, there’s no smoking gun in the server control panel. it seems like you were able to pinpoint that the issue was around that file. you mentioned you were experimenting with ffmpeg, if there were any encoding settings that were different for that file, that could easily be the culprit.
in the case of @andrei_jay’s files, i believe that all of the files were encoded with identical settings from an encoding profile in handbrake, so different encoding settings wouldn’t explain why some files worked and others didnt, it seemed kind of random. on the back end, peertube is generating three different resolution renditions of each video uploaded via ffmpeg, and its not the beefiest server, so i guess even just having multiple people uploading at the same time could result in things taking longer. but unfortunately i’m not sure how to access any information about the status of those processes, i would guess there might be a way to interact with the peertube services via command line that might give me more info than the admin panel on the site, but its a little opaque to me.
anyways, will keep an eye out for any more issues, its helpful that people have been communicative when they encounter things like this.

1 Like

I havnt had a chance to look at this yet / read this fully, but from admin panel you can see the tasks / errors in the GUI. I can make you admin @pixelflowers. But yah will take a look tomorrow prob.

I imagine it could be machine load related.

@pixelflowers @palomakop @andrei_jay

taking a wee look into this now.

in the job panel i can see that some transcoding jobs were failing

for some of them the messages says:

Error: ffmpeg was killed with signal SIGKILL

which seems to imply that something (peertube?) killed the transcoding job - maybe it was taking too long ?

on the 1st of jan the cpu is at 100% for around 12 hours. so my guess is that some jobs may have timed out during these times.

one issue here is the droplet that videos.scanlines runs on is too small (only 1cpu). since it does appear to be getting used more these days i think we could justify bumping it up to a 2cpu droplet. this should solve some of these issues (and transcode faster in general


the other reason i can see for jobs failing is:

ffmpeg exited with code 1: Conversion failed!

im guessing this one is related to the format of the original video that is uploaded.


here is the user : name of the transcode jobs that failed in the last week:

sigkill:

150f25fe-fa93-4dcd-b692-16e892485ed2 - andrei_jay : Ephemeris Time Block1-1
6d0ebb97-1043-4250-9cab-1805f6ac98ee - pixelflowers : 2020-12-30-02-40-20-logo-1280

conversion failed:

02cac947-55dd-465e-b663-99f0748f183e - deme : #2.mp4
dc043831-9e82-4f13-af3f-8cff12ec4091 - deme : #3.mp4
7133c865-874d-4713-aa58-f5865dd1b76b - deme : #4.mp4
9e330284-f8e8-49f7-8522-d182bca203e8 - pixelflowers : 2020-12-30-02-40-20-logo-1280
1 Like

so yeah, the ephemeris time block 1 failed at transcoding but did upload. I just today went in and deleted the untranscoded video from my videos.scanlines account and have tried 3 times to upload again (this time with much faster internet connection) and what happened each time is everything looked like it was uploading fine and then instead of getting to 100 percent and giving me a ‘publish’ button, the uploading screen would just reset to its initial state prompting me to ‘upload a video’. I’m on a hard line connection this time because i wanted to make sure it wasn’t an issue with wifi instability. the settings on the video itself should be identical to the other videos i uploaded which all seemed to transcode eventually (tho some of them took more than a couple of tries, with the same disapearing uploads page thing). wacky fun occult peertube stuffs!

1 Like
chat.scanlines.xyz