Waaave pool Midi Controls, troubleshooting

I just got a Waaave pool and in using it it seems like many of the controls using my nanokontrol2 are not mapped. The knobs across the top of the unit all are correct, luma, mix, etc. but the sliders and buttons on the left seem to either do nothing or clear the effects while pressed.

What are the best options I have to troubleshoot? Though no a complete technophobe, I am not familiar with code or coding unfortunately.

Did you use the Nano Kontrol editor to upload the scene settings from here?

When none of the buttons next to the sliders are lit, the range of the sliders is small enough that it can look like they aren’t doing anything, and with a stock Nano Kontrol the buttons are momentary rather than toggle so your faders will always be operating across the smallest possible range and most of the buttons will only be active while you’re physically pressing them.

My nanokontrol showed up about a week after everything else when I made my Auto_Waaave and by that time I’d totally forgotten about the scene settings and just plugged it in and half the controls didn’t work properly.

1 Like

aH yeah, seems likely to be it that I didn’t upload the scene settings.

So I’ll install that program on ANY computer and then load the setting into the Nanokontrol2. Or is it something that needs to be installed onto the Raspberry pi?

Been a while since I bought a midi controller let alone one smart enough that it can flash a program to it.

yep, solved it. I missed that part in the readings I did, Thank you!

2 Likes

Didn’t wanna create new topic for nano related issues. Im on windows, ive got all of the apps running, all of them recognisse nano kontrol2, except video_waaaves 2.5. I already tried waaave_pool on rpi (much fun!), on linux (had problems on gpu side of things), now i am trying to run it on windows, and tbh with vc setup, i don’t have any clue how to debug or solve this… Any help would be appreaciated!!!

video waaaves doesnt come premapped to my default nanokontrol2 scene, it has its own seperate set of (incomplete) cc mappings for parameters which is listed on the github readme at the moment

1 Like

So its good news then, meaning everything works correct! By the way, Your tools are amazing and very fun to play with, big respect!

1 Like
chat.scanlines.xyz