Waaave Pool sd image problems

Hi all, recently discovered Waaave Pool and am very excited to get started! Unfortunately I’ve run into issues pretty early on. I’ve purchased a 3B+ and flashed the WP1_5PAL.img to a new(ish) SD-card (used recently successfully in one of my audio synths). No problems flashing in Balena. But when I try the card in the RPI 3B+, I see a repeated flashing cycle of 4 slow flashes and 7 quicker. According to here these mean:

4 flashes: start.elf not launch-able
7 flashes: kernel.img not found

so…could the current images be corrupt? Tried the NTSC one too… Thanks!!

UPDATE: To rule out hardware issues, I tried installing Raspberry Pi OS using the same card and can do so without problems. Not sure how to proceed :frowning:

i believe there is some change with the newest run of pi 3b+'s that makes them unable to boot with certain images which worked with the older ones. my understanding is that this is because the WP/vserpi images are based on an old kernel. there is a change that needs to be made to the image that would fix it (updated bootloader files) which hasnt been made yet but likely will at some point soonish (read: next couple months). so i believe your options would be to wait for that to happen, or if you want to get running sooner, get a 3b (NOT “plus”) model, those don’t seem to have the same issue. (or if you are very technical, you could look into updating the image yourself.)

1 Like

There’s a fix for the 3b+ on the discord

1 Like

Thanks! Sounds great…searching…(but not finding)…(Discord as in Lords of light?)

UPDATE: Ah, think I found it on Video Synthesis Ecosphere: Discord

Pretty technical, just need to find the instructions… :slight_smile:

Scroll up in the raspberry pi channel and you’ll find this: Raspberry Pi 3B+ only booting RPi OS - Raspberry Pi Forums

1 Like

Final update (removed all earlier nonsense!): Well, replacing the necessary .dat files (as seen in the above linked instructions) did seem to correct the boot issue after all.I’m in, just need to wait for my webcam to arrive! Glad that’s solved! Thanks for the guidance.