What the!?!?!ERROR! "/usr/lib/libstdc+ +.6.dylib for architecture x86_64"

yeah, so i’m not sure what this one means, and it effects all past versions i try to run. i’ve tried looking through help etc… if anyone has suggestions please let me know.
Screen Shot 2022-10-25 at 9.08.03 PM

forgot, but this error was on macOS… and i couldn’t figure anything out…
happened to grab a cheap PC in the meantime and can run videowaaaves etc… although the video playback is choppy, like low frame rate for whatever reason so still messing around trying to get back up and running!

So, yeah, i can run on this other computer but can’t get it up past 4fps… uggghhhh

so a quick search gives me this result on that error.

theres a bunch of information in the thread worth reading but probably the quickest hacky fix would be

is this a fresh install? are you running on m1 mac? what OSX? what version of Xcode?

for low framerates always try smaller i/o resolutions and smaller buffer lengths. for pcs running integrated intel graphics chips instead of AMD/NVIDIA there is gonna be a hard cap on performance

Thanks! i’ve read those pages as well and they didn’t seem to be of much help. Ive since tried several other work arounds and am having a different problem currently. Yes I’ve tried fresh installs of everything… actually have a thread in the discord too and have gotten a little help but still not working.

For my PC i’m pretty sure now that its a hardware performance issue

The newer versions of macOS don’t seem to allow running previous versions of Xcode… which is crappy too btw

Okay! thanks to some notes on the scanlines board, i went back and started over again. i followed the M1 Big Sur tutorial (although i’m not on that version of OS or have an M1). Video Waaaves now builds like normal… but new problem!!! I don’t get any display windows… so the app runs, but I don’t see get the controls or display. Any ideas anyone?

this is about where i’ve got exactly no ideas… but hopeful that some modern macfolx have seen this before

1 Like

Screen Shot 2022-11-14 at 11.21.21 AM

FIXED!!!
basically libndi_advanced.dylib and not libndi.4.dylib needed to be in the correct location… reading the debug results helped me figure out where i needed to copy the correct file from the ndi video monitor app

1 Like

hooray!